.net core always running / Always On in Azure. how to enable?


#1

I’m adding an enqueue job, where I need a job is to be always-on / Running job. (Status: processing)
This job will consume messages from rabbitMq, so I want this job to be listening and always on.
When the application starts, this job working fine. But after a while, this job completed automatically (status: Succeed). This happens only when the application is hosted in the Azure environment (setting changed start mode: “Always On”).

When I hosted the above same application in the windows server. The enqueue job is always on. (Status: processing) for many days.

In IIS, setting changed as per (https://docs.hangfire.io/en/latest/deployment-to-production/making-aspnet-app-always-running.html)

start mode: “Always On”
Idle Timeout: “0”
Preloaded Enabled: “True”

My question is why in Azure, the enqueue job will be completed automatically. Can anyone please help me to resolve this issue?