Trigger Now button in Recurring Jobs always disabled

recurring
Tags: #<Tag:0x00007f69fc0093e0>

#1

On my production deployment, from the Recurring Jobs page, I can never trigger a job. Even if selecting the checkbox(es) of jobs, the button never enables. I have to always run a LINQPad script to trigger the job. However, in my development environment, I can choose jobs and click ‘trigger’ without issue.

Any ideas?

I’m running Hangfire 1.6.8 (might be a bit old, I didn’t look yet to latest release)


#2

Hi Terry,

Are you using the same browser on both environments, if yes do they have the same version?

Have you tried editing the html through browser tools, by removing the ‘disabled’ attribute from the button and trying to select the job and execute (I am guessing job should execute since it’s working through linkpad).

Sorry if this doesn’t help much, but if this is an UI bug more detail is needed.


#3

You were right. The production server was locked down for outbound internet traffic and was still stuck using IE 11.0.

We got a copy of chrome installed on there then the button enabled.

For more information in case you want to look at it. I attached an image of the button in IE. Even after I removed the disabled attribute and was able to click it, do so did nothing (the job wasn’t submitted).


#4

Usually production servers have some browser from the stone age :smiley: I am glad ti was just this.
When you enabled the button manually, have you selected a job from the list before executing, although it doesn’t matter I guess, I would’t consider this a bug, but not my decision to make.


#5

I did select a job before clicking submit. Not sure why nothing happened when clicking it. As you said, going to use chrome so I will let someone else decide if they want to pursue fixing this.