Sql Server, invisibilityTimeout set to 30 minutes appears to not work

I have my invisibilityTimeout set to 30 minutes, just like your example above. See my screenshot. But, last night I experienced a job that was long running (more than 5 minutes, less than 10 minutes), and HF retried the job 9 times, every 5 minutes. The job never failed, it just took longer than 5 minutes to run.
So it appears that the timeout is not setting properly and defaulting to 5 minutes instead of 30. Any insights or advice? I’m thankful for the limit of only running 10 times… and not indefinitely!

screenshot 1

screenshot 2

Can’t reproduce this, looks like the problem is not in the invisibility timeout. What Hangfire version do you have? Please enable logging to see if there is any exception.