Recurring jobs firing the first time but not repeating

I’m having an issue with recurring jobs.

I’ve got a job configured to run every day at 10am with the following cron string ’ 0 10 ? * MON,TUE,WED,THU,FRI,SAT,SUN’. It fires the first time succesfully, but the next time it comes due it does not fire. The dashboard says the next job is scheduled for X minutes/hours in the past. (The dashboard is running on a seperate server thus the warning about not loading file or assembly.

I have tried updating the job to run every 5 minutes and that does work. I also tried scheduling a run to fire for the first time the next day, thinking maybe something was turning off overnight, however this ran succesfully the next day but then didn’t trigger the day after.

I can’t find any exceptions in our logs. I’m at a bit of a loss as to what to look for next. Any help is much appreciated!

EDIT - one last piece of the puzzle - manual triggering fails with a 500 error, but that might be because this is running on a different server?

I’ve been continuing investigating this - still not got an answer but perhaps another clue.

It looks like when the event doesn’t fire the Score in the Set table is set to -1.

Also I’m currently on 1.7.19