Hangfire Discussion

Dashboard not visible (on azure websites)?


#1

Hi guys,

Just started using Hangfire - awesome :smile:

All works fine locally but when I publish my app to my hosting (in this case Azure websites), the dashboard does not show up. No error, no nothing…

The code executes the scheduled jobs (I setup an email confirmation) and the db get updated with the schema. So behind the scenes all seems to work.

I am on .net 4.5.

Any ideas?


#2

Actually I’ve had the same problem. After moving the code in Startup.Auth.cs around (I’d placed it after by cookie auth parts (i.e. cookieauth, facebook and google and before the OpenId connector).

Maybe this helps.

Regards
Stephen


#3

Hi Stephen,

Thank you for your response. I am not using the Startup.Auth.cs in this case. The file is not present. Any other ideas?


#4

Not from my side, sorry.


#5

Corstiaan,

Any luck finding the problem. I’m having the same issue on AppHarbor.

John


#6

No, still no luck :frowning:

Will keep looking and post solution as soon as I find it. Hope you will do the same :smile:

Best,
Corstiaan


#7

Hey, We were having the same issue. According to http://docs.hangfire.io/en/latest/users-guide/deployment-to-production/configuring-authorization.html, you HAVE to have the Dashboard Authorization package installed to view the dashboard from outside of localhost. As soon as we added the package, and configured it we were good to go. Hope this helps.

Geddy


#8

Thanks. Gonna try this asap :smile:


#9

Hi,

I have the same problem, locally the hangfire was working out-of-the-box. On publishing to an online server (IIS7). The dashboard is simply not accessible. So I did not publish to Azure, just a local machine.

If I hookup the online database with the local app, I can see the server mentioned in server listing, even when it started the process, but the dashboard is not available online.

Adding the suggested solution on configuration (see above) does not solve the problem.

Anyone can help me?

Francis.


#10

Hi Corstiaan,

Did that solution work for you?


#11

I’m having the same issue, dashboard works as expected on my dev machine, some developers in the team cannot browse the dashboard on their local hangfire instance.

“No type was found that matches the controller named ‘hangfire’.”


#12

Yes and no. I think this solution works but I am using Nancy, not asp.net MVC. At this time I did not yet manage to get the authentication issue fixed. However, when tinkering with it, using nancy, I did manage to hack something together that let me view the dashboard page. BUT, Hangfire want to authenticate EVERY request made from the dashboard to the server. This includes polling request to check for status, calls to css files and other resources, etc. I have only gotten to the point where the initial call to the dashboard was authenticated, but no css was loaded and the dashboard was not updated realtime. So, I think its safe to say that when you hook up the dashboard authorization package as described above, it should function as intended. It’s just that I am using Nancy that stuff gets a little different and I did not yet get around to integrating it properly. As of now, I am flying sans dashboard… Work in progress though :smile: Hope this helps.


#13

Thanks a lot, it worked for me too.
I needed to put Hangfire config before a dependency injection container (Ninject) config in WebApiInitializer.Configuration method.