Background jobs not triggered till web application accessed

Nice tool you have here, however my scheduled jobs don’t get triggered.

I’ve created a class that handles the initiation of the background job server as well as dispose method with gets called from global.asax file. Hangfire itself gets started using OWIN from the recommended startup class (not sure if i’m missing something here already).

I’ve also made sure the auto start options are set as an extra on the web server. Through all the configs and classes created i can get the job to run but only after calling the web app


I have come up with the same problem as yours.

First, I have an owin class here at the root of the website folder.

Second, I have a HangfireBootstrapper which is responsible for starting the hangfire server.

Thirdly, I have also made proper change in IIS config file, made the application pool to be always running.

The problem is even if I have done all of those required configs demonstrated in the guideline, I still have your problem. Hope we could find out the reason.