THIS BOARD - cant edit a post

When I try to edit my own post, I get “body is too similar to post” or something like that. Has anyone got around to fixing this?

any update on this? Should we use Stackoverflow instead?

Some googling suggest that it is a bug in Discourse. So the Discourse board might need to be updated.

I had the same issue. Being told “Body is too similar to what you recently posted” every time I tried to edit the post I just wrote.

I had to instead post a new almost identical post with my edited changes and mark the old message as deleted. Those deleted post still exist and can be read though, so it is very annoying.

Current this board is running: Discourse 2.3.0.beta5
The board is running: Discourse 2.6.0.beta1

It might be time to update the board, and then this bug would hopefully be fixed. It is driving me nuts not being able to edit my posts.

Unfortunately I’ve tried to upgrade Discourse a bout a month ago, but everything crashed – there was a problem with PostgreSQL (but I don’t remember exactly). So I’ve rolled back upgrade and will try again later, taking all the snapshots and backups before doing anything with that box.

1 Like