.NET Core app still getting 2 servers started one with 10 workers, how to ensure only 1

Tags: #<Tag:0x00007faff69334a8>

.net core 2.2 web app. I need to ensure that for a given job, there are never more than one running. So I configured my startup options with this
app.UseHangfireServer(new BackgroundJobServerOptions { WorkerCount = 1 });

Why do I still get 2 servers , with one of them having 10 “workers”? I have configured what I gather from the documentation to only have a single worker.

image

Are you calling both UseHangfireServer and UseHangfireDashboard that caused me to get two servers.

1 Like

I have the same issue and I’m calling both of those. It looks like you’re supposed to call both Use methods but the dashboard is spinning up another worker process?

Figured it out…I should use AddHangfireServer and configure options there instead of using UseHangfireServer alongside UseHangfireDashboard