Default queuing filter ignored when creating a batched action

Tags: #<Tag:0x00007f1858f74ed8>

We provide a custom default queuing filter with in our DI. It is custom as we want to dynamically assign job queues based on job parameters. However, when we try to start a batch, the task supplied is instead thrown into Hangfire’s default queue, ignoring our default filter.

Are we missing a step when setting up our DI registry?